Go Back  MyG37 > Tech Area > Audio, Video & Electronics
Reload this Page >

Help Car came with remote start installed, how to disable/remove?

Notices
Audio, Video & Electronics Post questions, reviews, and other general info about the G's Nav, sound system, satellite radio or aftermarket stereos

Help Car came with remote start installed, how to disable/remove?

Old 07-04-2019, 12:27 AM
  #1  
burnt_toast12
Registered User
Thread Starter
 
Join Date: Jul 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Car came with remote start installed, how to disable/remove?

Hello! I purchased my 2011 G37x sedan a year or so ago and have already put on 20k trouble free miles mechanically and electrically. However, I knew the car came with an aftermarket remote starter installed as I received an aftermarket remote, and next to the mirror there's an antenna that looks like this:

Based on this I can tell the unit installed is an Omegalink Excaliber. Upon purchasing the car I tried to the best of my ability to get the aftermarket remote to work, but it didn't seem to work for lock/unlock or anything, remote starting was out of the question and I didn't even need it so I thew that remote out. However, starting a couple weeks ago, something re-awoke this remote start unit. Every time I enter the car I hear a series of clicks from under the steering wheel (likely the control box for the remote start?) and then a blue led blinks on the antenna 4 or 5 times. It's annoying considering this thing never used to bother me, and I believe it might be phantom draining my battery, as ever since this started happening my morning starts are much weaker than normal, this might just be the weather though...

Either way, might anyone here have the same or similar unit and could help me out on disabling this unit so it doesn't bother me like it used to, or completely uninstall it? I've been warned about messing with these units as I've heard it can either make my factory remotes unusable or not allow me to start my car. Thanks for any help/suggestions!
burnt_toast12 is offline  
Old 07-06-2019, 07:25 PM
  #2  
Surfnazi
Registered User
 
Join Date: Nov 2013
Posts: 1,348
Received 97 Likes on 92 Posts
Did you check keyfob battery
Surfnazi is offline  
Old 07-06-2019, 07:59 PM
  #3  
burnt_toast12
Registered User
Thread Starter
 
Join Date: Jul 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Key is brand new with purchase of the car, so it's less than a year and a half old.
burnt_toast12 is offline  
Old 07-07-2019, 09:34 AM
  #4  
NealP
Premier Member
 
NealP's Avatar
 
Join Date: Aug 2014
Location: MA
Posts: 464
Received 46 Likes on 42 Posts
If you can locate the box, which is usually zip tied under the steering column, you can try just disconnecting it to see if the car operates normally. Otherwise I'd say take it to a pro
NealP is offline  
Old 07-07-2019, 08:01 PM
  #5  
steveng37
Registered User
 
Join Date: Dec 2018
Posts: 56
Received 2 Likes on 2 Posts
I would take it to the professionals to get it removed. The wires under there are most likely soldered. Shouldn't be more than $50-60 to have it removed
steveng37 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Joyryde
General Tech Questions
14
05-10-2019 07:04 PM
JohnEnglish
The M - Spot
14
09-25-2010 02:33 AM
tbear
Body Interior Exterior Lighting
13
07-10-2010 09:12 PM
classy37
Audio, Video & Electronics
1
08-02-2009 06:35 PM
kevinyo
Audio, Video & Electronics
3
09-23-2008 02:54 PM


Thread Tools
Search this Thread
Quick Reply: Help Car came with remote start installed, how to disable/remove?


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.