Notices

BRAKE light during hard acceleration

Old 11-25-2011, 08:39 PM
  #1  
mystakin
Registered User
Thread Starter
iTrader: (2)
 
mystakin's Avatar
 
Join Date: May 2010
Location: Branchburg, NJ
Posts: 880
Likes: 0
Received 0 Likes on 0 Posts
BRAKE light during hard acceleration

today was a great day. got 40% off a huge shopping purchase and so i treated my car to a little treat. Went ahead with getting her darker front tints as i had a scratch on the passenger window and 35% was seeming a bit too light for me. Also went ahead with getting a windshield strip which im not sure if i love or hate but hopefully it'll grow on me. Anyways, after leaving the tint shop, I noticed my brake light on the dashboard turned on under hard acceleration from a red light. This caught me off guard and i thought i was just seeing things.. but no, whenever i would 'floor' it and the car would take off, the brake light would turn on. i wouldnt get the beeping caused when you press the foot parking brake while driving which says something along the lines of, "please remove parking brake" or something like that. No beeps or any notifications on the dash from this hard acceleration other than the red Brake light illuminating.

anyone had a similar issue? i mean its not too annoying since there is no beeping, but having that light come on seems to draw my attention away from the road which now makes it a safety factor.
mystakin is offline  
Old 11-25-2011, 09:44 PM
  #2  
hobbs
Registered User
 
Join Date: May 2011
Location: SoCal
Posts: 501
Likes: 0
Received 38 Likes on 31 Posts
Low brake fluid?
hobbs is offline  
Old 11-26-2011, 01:17 AM
  #3  
mystakin
Registered User
Thread Starter
iTrader: (2)
 
mystakin's Avatar
 
Join Date: May 2010
Location: Branchburg, NJ
Posts: 880
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by hobbs View Post
Low brake fluid?
not sure, ill check in the morning. had the stealership do the 10k oil change just on wednesday so i think they wouldve told me if anything seemed low, but who know..
mystakin is offline  
Old 11-26-2011, 09:02 AM
  #4  
Can'tGme
Registered User
iTrader: (1)
 
Join Date: Aug 2011
Location: Kentucky
Posts: 623
Received 16 Likes on 14 Posts
Originally Posted by hobbs View Post
Low brake fluid?
Correct. Happened to me in my Z before.
Can'tGme is offline  
Old 11-26-2011, 09:40 AM
  #5  
trp244
Registered User
 
trp244's Avatar
 
Join Date: Mar 2011
Location: CT
Posts: 151
Likes: 0
Received 5 Likes on 5 Posts
I'm betting it's not the brake fluid, since I have had the same issue and I found that the parking brake is just loose enough to trip the dash light and not the chime (warning sound) just after hard acceleration. I plan on having dealership take a look soon and will update then.
trp244 is offline  
Old 11-26-2011, 11:54 AM
  #6  
htwnlovaboy
Registered User
 
htwnlovaboy's Avatar
 
Join Date: Sep 2009
Location: HOUSTON, TX
Posts: 136
Likes: 0
Received 0 Likes on 0 Posts
the same thing happend to me this morning.
htwnlovaboy is offline  
Old 12-19-2012, 12:36 PM
  #7  
bsaot
Registered User
 
Join Date: May 2012
Location: Los Angeles
Posts: 17
Received 0 Likes on 0 Posts
Sorry, has anyone found the solution to this problem. I recently got KW V3's installed and have been having the same issue. After hard accelerations, my brake light also turns on. Same exact issue.. please let me know if you find out why.
Thanks!
bsaot is offline  
Old 12-19-2012, 06:09 PM
  #8  
nukee26
Registered User
 
nukee26's Avatar
 
Join Date: Oct 2011
Posts: 312
Received 12 Likes on 8 Posts
Try topping off your brake fluid. It fixed the issue when I had it even though the level was still within the low/high band.
nukee26 is offline  
Old 12-19-2012, 08:21 PM
  #9  
Himalaya
Registered User
 
Join Date: Oct 2011
Posts: 362
Likes: 0
Received 4 Likes on 4 Posts
either brakes are really bad or brake fluid is low. I went in today and got the brake fluid topped off and the problem went away
Himalaya is offline  
Old 12-19-2012, 09:29 PM
  #10  
nbast
Registered User
 
Join Date: Jul 2011
Location: Upstate NY
Posts: 207
Received 4 Likes on 4 Posts
As everyone else has said, it's low brake fluid. I had the same thing happen to me two weeks ago. Topped off the fluid and no more light...
nbast is offline  
Old 12-20-2012, 02:23 PM
  #11  
Emon Crew
Registered User
 
Join Date: Nov 2007
Posts: 235
Received 0 Likes on 0 Posts
I wouldn't just go with low brake fluid, Id have your rear brakes checked out too...once my rear brakes went that was the first light to pop on....then came the yellow exclamation, then the vdc off then the slip....good luck
Emon Crew is offline  
Old 12-20-2012, 03:16 PM
  #12  
WILLDOGS
Registered User
 
Join Date: Jan 2012
Posts: 59
Received 0 Likes on 0 Posts
Its the low brake fluid, but the reason your fluid is low is because your pads are low.

Make sure you get your pads checked out, its a way of warning you early.
WILLDOGS is offline  
Old 01-11-2013, 06:46 PM
  #13  
alanro
Registered User
 
Join Date: Jan 2013
Location: taylors, s.c.
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
my 09S coupe did the same, even though the fluid level was above min., it still needs to be topped off, and no more light.
Dealer went ahead and warranty replaced front brake backing plates-pads-turned rotors, due to a TSB about noise,vibreation, harshness[NVH] on the front.
I paid 130.00 for rear turn rotors, and de-graze pads[had 50+%] life remaining.
I noticed that on morning starts, no more sqealing when backing out of driveway.
alanro is offline  
Old 01-12-2013, 10:09 PM
  #14  
welshg37owner
Registered User
 
Join Date: Aug 2009
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
I have that problem (now at 50,000) miles. No issue since fluid top off at service today but will be watching out for any indications of brake wear.
welshg37owner is offline  
Old 05-11-2016, 12:32 PM
  #15  
Dradams13
Registered User
 
Join Date: Jan 2016
Location: Chicago, IL
Posts: 31
Received 1 Like on 1 Post
Originally Posted by Emon Crew View Post
I wouldn't just go with low brake fluid, Id have your rear brakes checked out too...once my rear brakes went that was the first light to pop on....then came the yellow exclamation, then the vdc off then the slip....good luck
having the same problem. hard excel, brake light comes on, then VDC light illuminates and doesn't go off. Manual says to restart and it resets light.


this works. i'll try the brake fluid fix and see if that works. just got a 2011 g37x sedan used 90k miles. I hope that it's nothing big, I love this car.
Dradams13 is offline  

Thread Tools
Search this Thread
Quick Reply: BRAKE light during hard acceleration


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.