Forum extremely slow - MyG37



Site Feedback & Suggestions For posting feedback and suggestions regarding MyG37.com

Forum extremely slow

Reply
 
 
 
Thread Tools Search this Thread
Old 07-19-2017, 08:27 PM   #1
dbeachy1
Premier Member
Thread Starter
iTrader: (1)
 
dbeachy1's Avatar
 
Join Date: Sep 2013
Location: Manassas, VA
Posts: 85
Thanked 4 Times in 4 Posts
Forum extremely slow?

Hi all,

I was away from the forum for a while, but after coming back a few days ago, the forum is extremely slow & laggy (I tried this on multiple browsers across several days). It takes ~20-30 seconds for any given page to load, and looking at the stats on the main page just now, it says:
Quote:
Currently Active Users: 856 (53 members and 803 guests)
Is the forum experiencing a DDOS attack? Or are there really that many valid guest users hitting the forum and the forum's servers simply can't keep up? In its present state, the forum is unusably slow.

Last edited by dbeachy1; 07-21-2017 at 11:54 PM.
dbeachy1 is offline   Reply With Quote
Old 07-20-2017, 09:55 AM   #2
telcoman
Registered User
 
Join Date: Sep 2012
Location: NJ
Posts: 1,301
Thanked 111 Times in 94 Posts
Check your internet connection speed
telcoman is offline   Reply With Quote
Old 07-20-2017, 11:02 AM   #3
blnewt
Modr8r & DIY cheapsk8
iTrader: (11)
 
blnewt's Avatar
 
Join Date: Nov 2009
Location: New Mexico
Posts: 22,032
Thanked 4,200 Times in 3,566 Posts
Been working as normal for me (DSL 20 Meg)
blnewt is offline   Reply With Quote
The Following User Says Thank You to blnewt For This Useful Post:
dbeachy1 (07-21-2017)
Old 07-21-2017, 02:43 PM   #4
kiseliok
Premier Member
iTrader: (9)
 
kiseliok's Avatar
 
Join Date: Aug 2016
Location: Charlotte, NC
Posts: 749
Thanked 94 Times in 87 Posts
Quote:
Originally Posted by blnewt View Post
Been working as normal for me (DSL 20 Meg)
What's DSL?!

I haven't had any issues. Classifieds have always been slower, but I think a back-end search is the reason for that. Rest of the forum is pretty snappy.
kiseliok is offline   Reply With Quote
The Following User Says Thank You to kiseliok For This Useful Post:
dbeachy1 (07-21-2017)
Old 07-21-2017, 02:53 PM   #5
micafd3s
Registered User
iTrader: (2)
 
micafd3s's Avatar
 
Join Date: Jun 2015
Location: NYC|PA
Posts: 1,120
Thanked 97 Times in 86 Posts
you gotta feed that hamster... and grease that wheel
micafd3s is offline   Reply With Quote
Old 07-21-2017, 03:32 PM   #6
telcoman
Registered User
 
Join Date: Sep 2012
Location: NJ
Posts: 1,301
Thanked 111 Times in 94 Posts
Quote:
Originally Posted by kiseliok View Post
What's DSL?!
Ever hear of Google?

https://en.wikipedia.org/wiki/Digital_subscriber_line

Telcoman
telcoman is offline   Reply With Quote
Old 07-21-2017, 03:34 PM   #7
kiseliok
Premier Member
iTrader: (9)
 
kiseliok's Avatar
 
Join Date: Aug 2016
Location: Charlotte, NC
Posts: 749
Thanked 94 Times in 87 Posts
Quote:
Originally Posted by telcoman View Post
Ever hear of sarcasm?
kiseliok is offline   Reply With Quote
Old 07-21-2017, 09:46 PM   #8
dbeachy1
Premier Member
Thread Starter
iTrader: (1)
 
dbeachy1's Avatar
 
Join Date: Sep 2013
Location: Manassas, VA
Posts: 85
Thanked 4 Times in 4 Posts
So it turns out that the forum is only super-slow for me if I'm on my VPN -- otherwise, it's fine. From doing a speed test while on my VPN, I'm getting ~120 mbps up and down, and off my VPN I'm getting 160 mbps up and down, and all other sites are fine while on my VPN. So whatever it is, the issue is specific to myg37.com and ExpressVPN.

EDIT:
Another update here: after uninstalling and reinstalling my VPN client, the forum is loading fine again even under VPN. Go figure...

Last edited by dbeachy1; 07-21-2017 at 11:55 PM. Reason: Added note
dbeachy1 is offline   Reply With Quote
Old 07-22-2017, 10:09 PM   #9
kiseliok
Premier Member
iTrader: (9)
 
kiseliok's Avatar
 
Join Date: Aug 2016
Location: Charlotte, NC
Posts: 749
Thanked 94 Times in 87 Posts
If you running into slowness, try running some network tools.

$ ping myg37.com # basic ping to the server

Pinging myg37.com [104.28.29.249] with 32 bytes of data:
Reply from 104.28.29.249: bytes=32 time=19ms TTL=55
Reply from 104.28.29.249: bytes=32 time=19ms TTL=55
Reply from 104.28.29.249: bytes=32 time=16ms TTL=55
Reply from 104.28.29.249: bytes=32 time=17ms TTL=55

$ tracert myg37.com # will give you a general idea on how many hops you are taking and how long each one takes

Tracing route to myg37.com [104.28.29.249]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms
2 28 ms 17 ms 34 ms
3 38 ms 33 ms 43 ms
4 13 ms 12 ms 17 ms
5 15 ms 22 ms 23 ms
6 27 ms 29 ms 30 ms
7 20 ms 22 ms 23 ms
8 81 ms 16 ms 20 ms
9 17 ms 21 ms 30 ms
10 24 ms 18 ms 18 ms
11 23 ms 22 ms 22 ms 104.28.29.249

$ nslookup myg37.com # Will tell you what DNS server you are using and proper dns response
Server: google-public-dns-a.google.com
Address: 8.8.8.8

Non-authoritative answer:
Name: myg37.com
Addresses: 2400:cb00:2048:681c:1cf9
2400:cb00:2048:681c:1df9
104.28.28.249
104.28.29.249


Also, if you are using your isp's dns, I'd recommend trying something like google (8.8.8.8 / 8.8.4.4). It's quite a bit quicker and a lot more reliable. Also, some argue, your browsing habits are much safer that way. (Which your VPN might be reconfiguring after connection, depending on your options.)
kiseliok is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 08:35 AM.


Copyright 2002 - 2017, MYG37.COM All Rights Reserved.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: