Notices
Engine, Drivetrain & Forced-Induction
Have Technical Questions or Done Modifications to the G37? Find out the answer in here!

2010 G37 SHIFT P Warning

Old 03-07-2010, 10:02 PM
  #1  
nycjoker
Registered User
Thread Starter
 
Join Date: Mar 2010
Posts: 16
Likes: 0
Received 0 Likes on 0 Posts
2010 G37 SHIFT P Warning

I picked up a 2010 G37x about a week ago. I love the car. However, I noticed that 8 out of 10 times when I put the car in park and turn off the ignition I get a SHIFT P warning on the display. If I get out of the car with the intelligent key the car chime continuously.

According to the manual this should only occur when the ignition is turned off and the car is not in park (P) position. I've been able to reproduce the problem many times with the selector lever in in the park (P) position.

Has anyone else experienced this issue?
nycjoker is offline  
Old 03-08-2010, 02:09 AM
  #2  
da mayor
Registered User
iTrader: (2)
 
da mayor's Avatar
 
Join Date: Sep 2005
Location: Long Island, NY
Posts: 5,655
Received 33 Likes on 29 Posts
bring it back to the dealer. sounds like it's not lined up right
da mayor is offline  
Old 03-08-2010, 02:47 AM
  #3  
gtracing
Registered User
iTrader: (3)
 
Join Date: Dec 2008
Location: Richmond, B.C.
Posts: 876
Received 5 Likes on 4 Posts
yea, sounds like bad wiring somewhere....
gtracing is offline  
Old 03-08-2010, 09:52 AM
  #4  
PascalT
Registered User
 
Join Date: Mar 2010
Location: Montreal
Posts: 322
Likes: 0
Received 0 Likes on 0 Posts
Haven't had this problem, it does seem like there's something wrong in there.
PascalT is offline  
Old 03-08-2010, 01:28 PM
  #5  
nycjoker
Registered User
Thread Starter
 
Join Date: Mar 2010
Posts: 16
Likes: 0
Received 0 Likes on 0 Posts
I'm going to schedule a service appointment and see what happens. I'll post the result.
nycjoker is offline  
Old 03-09-2010, 12:28 AM
  #6  
lokitiw
Registered User
 
Join Date: Mar 2009
Location: Prescott AZ
Posts: 75
Likes: 0
Received 0 Likes on 0 Posts
Nope it doesn't happen in AZ.
lokitiw is offline  
Old 03-09-2010, 10:22 AM
  #7  
JJSoCrazy
Registered User
 
Join Date: Feb 2010
Location: Yonkers, NY
Posts: 76
Likes: 0
Received 0 Likes on 0 Posts
Yea I have been having the same issue, it happens every now and then. I am going to call the dealer to schedule an appointment.
JJSoCrazy is offline  
Old 08-18-2013, 06:50 PM
  #8  
mjunod
Registered User
 
Join Date: May 2008
Posts: 37
Likes: 0
Received 2 Likes on 2 Posts
Any resolution to your problem? I have been having the same issue with a 2008 G37 Coupe. It does not happen often. Dealer has replaced several parts and checked all the wiring, but problem still occurs once in a while. The days it does happen, there was/is heavy rain or humidity. But they have not been able to reproduce it. I do have videos to show the problem though.
mjunod is offline  
Old 08-18-2013, 08:23 PM
  #9  
movinon
Registered User
 
Join Date: Mar 2010
Posts: 776
Likes: 0
Received 6 Likes on 5 Posts
I have had my 2010 for 3-1/2 years and never experienced your problem.

I turn the car off occasionally before putting it in park, and get the reminder then.

Tom
movinon is offline  
Old 08-20-2013, 01:44 AM
  #10  
DeepRumble
Registered User
 
Join Date: Jan 2012
Location: Lowell, IN
Posts: 213
Likes: 0
Received 2 Likes on 1 Post
I get the same warning every now and then. I just tap the shifter forward a bit and then its fine.
DeepRumble is offline  
Old 08-20-2013, 05:10 PM
  #11  
botlfed98
Registered User
iTrader: (11)
 
Join Date: Apr 2011
Posts: 1,109
Received 40 Likes on 38 Posts
Originally Posted by DeepRumble View Post
I get the same warning every now and then. I just tap the shifter forward a bit and then its fine.

same here...
botlfed98 is offline  
Old 04-29-2018, 06:18 PM
  #12  
flipmode007
Premier Member
 
Join Date: Dec 2012
Location: Ontario canada
Posts: 687
Received 37 Likes on 30 Posts
Sorry to bring this back alive but I would like to know if anyone find the fix for this problem as I am going through the same thing?
flipmode007 is offline  
Old 04-30-2018, 09:26 PM
  #13  
mjunod
Registered User
 
Join Date: May 2008
Posts: 37
Likes: 0
Received 2 Likes on 2 Posts
When I had this problem, the fix according to the dealer repair order was "found water in IPDM." The part replaced was 'CONTROLLER UNIT-IPDM-284B7-JK00A". Also listed expenses "VOR/CSC Handling-600". Since it was done under my extended warranty the order does not show cost for part and labor.

This was on a 2008 G37S coupe at 91K miles back in 2013. Have 156K miles now and the problem never returned. Tapping the shifter didn't help when I had the problem.
mjunod is offline  
Old 05-01-2018, 02:25 PM
  #14  
RMB5190
Super Moderator
iTrader: (2)
 
Join Date: Dec 2016
Location: Maryland
Posts: 2,326
Received 298 Likes on 267 Posts
Change the shift **** out recently flip?
RMB5190 is offline  
Old 05-03-2018, 01:17 PM
  #15  
terribleone
Registered User
 
Join Date: Feb 2010
Location: Madison, WI
Posts: 360
Received 27 Likes on 23 Posts
^I was wondering this too. Where the shift linkage is attached below the car is slotted. If the linkage got adjusted or moved a little the car can loose the "sensor" that says its in park.
terribleone is offline  

Thread Tools
Search this Thread
Quick Reply: 2010 G37 SHIFT P Warning


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.