Review Z1 Motorsports G37 Cold Air Intake - MyG37



Engine, Intake and Exhaust Subforum dedicated to breather or engine mods (intakes, exhaust, pulleys, N/A mods etc.)

Z1 Motorsports G37 Cold Air Intake

Reply
 
 
 
Thread Tools Search this Thread
Old 06-22-2017, 10:32 PM   #1
BigRek718
Registered User
Thread Starter
 
BigRek718's Avatar
 
Join Date: Jun 2017
Posts: 31
Thanked 0 Times in 0 Posts
Z1 Motorsports G37 Cold Air Intake

2013 G37x Sedan

First I would like to mention, ordering from Z1 was a breeze. And they shipped out my package extremely quick. I forgot to take some pictures because of how excited I was.

Installation of the intake was fairly straightforward, although the instructions were for the 370z. Everything seemed to match up. All the parts were there and were labeled correctly. Now the filters for this intake are mounted in front of the condenser. So pulling off the bumper even slightly is a requirement. No real way around it. Every part seemed to be of high quality. The metal intake pipes themselves were phenomenal. All the couplers and worm clamps were great too.

After the install, I fired the car up and was greeted by a nice deep sound. Everything fit together perfectly and I had no issues with anything.

All in all, Z1 Motorsports gets an "A" in every category. If you have any questions, don't hesitate to ask.
BigRek718 is offline   Reply With Quote
Old 07-16-2017, 07:46 PM   #2
G37fan09
Registered User
 
Join Date: Oct 2010
Posts: 144
Thanked 4 Times in 3 Posts
Are you planing on tunning?
G37fan09 is offline   Reply With Quote
Old 07-17-2017, 09:22 AM   #3
RMB5190
Registered User
iTrader: (1)
 
Join Date: Dec 2016
Location: Maryland
Posts: 1,263
Thanked 119 Times in 112 Posts
Appreciate the post. Snap some pictures and post if you would. Usually all we see are Stillen and takeda pics.
RMB5190 is offline   Reply With Quote
Old 10-09-2017, 09:01 PM   #4
AdamBritt
Registered User
 
Join Date: Sep 2017
Posts: 10
Thanked 1 Time in 1 Post
Sorry to bump but +1 on the pics. I am shopping around for a CAI and saw Z1 had one themselves today. I was curious about it and was going to ask on here but saw your thread.
AdamBritt is offline   Reply With Quote
Old 10-10-2017, 12:17 PM   #5
Brochenko
Registered User
 
Join Date: Jan 2016
Location: MN
Posts: 25
Thanked 4 Times in 3 Posts
I have the z1 intake as well. Installed around May of this year. This pic was right after the install.. It routes just like the Takeda and Stillen, the plus side (imo) is that z1 uses silicone piping through the radiator support, so you don't have do to any cutting unlike Stillen.

Brochenko is offline   Reply With Quote
The Following User Says Thank You to Brochenko For This Useful Post:
AdamBritt (10-10-2017)
Old 10-11-2017, 11:28 AM   #6
Eyeshield25
Registered User
 
Eyeshield25's Avatar
 
Join Date: Jan 2015
Location: NoVA
Posts: 212
Thanked 21 Times in 17 Posts
Z1 vs Takeda vs Stillen?
Eyeshield25 is online now   Reply With Quote
Old 10-11-2017, 08:27 PM   #7
4DRZ
Registered User
iTrader: (4)
 
4DRZ's Avatar
 
Join Date: Sep 2015
Location: Appleton, WI
Posts: 1,774
Thanked 143 Times in 119 Posts
Anyone with these intakes have any issues with CE lights for MAF sensors? I get them pretty much at will over 5k rpm in 3rd gear or if I bog the engine by accelerating in too high of a gear. I have the Z1 400hp kit on my sedan and no one at Z1 seems to know what is going on?
4DRZ is offline   Reply With Quote
Old 10-12-2017, 10:45 AM   #8
Brochenko
Registered User
 
Join Date: Jan 2016
Location: MN
Posts: 25
Thanked 4 Times in 3 Posts
I have not had any issues. I put them on this year around May, and in July I got a tune. It drove fine before the tune and still good with the tune.

I'd strongly recommend getting the pre-filter "socks" for them. If the MAFs are throwing a code they could be getting dirt/residue, water, etc on them. The filters don't come with a cover or shield for them (which isn't a good thing imo).

These are the ones I got, they fit the z1 filters:
Amazon Amazon
Brochenko is offline   Reply With Quote
Old 10-12-2017, 11:11 AM   #9
4DRZ
Registered User
iTrader: (4)
 
4DRZ's Avatar
 
Join Date: Sep 2015
Location: Appleton, WI
Posts: 1,774
Thanked 143 Times in 119 Posts
Quote:
Originally Posted by Brochenko View Post
I have not had any issues. I put them on this year around May, and in July I got a tune. It drove fine before the tune and still good with the tune.

I'd strongly recommend getting the pre-filter "socks" for them. If the MAFs are throwing a code they could be getting dirt/residue, water, etc on them. The filters don't come with a cover or shield for them (which isn't a good thing imo).

These are the ones I got, they fit the z1 filters: https://www.amazon.com/aFe-Power-28-.../dp/B0012I8LYQ
Where did you have your tune done?

Thanks for the idea with the filter covers. I don't think that is the issue as the filters are extremely clean. I wonder how much those limit air flow and how effective they are for resisting water. I keep waiting for Z1 to create a mountable shield for their filters like Stillen.

I had to buy a cable from Z1 this morning to try to diagnose the tune. Today Jon at Z1 told me that he has never seen a MAF sensor code on any 370 or G37. After putting me on hold twice he told me that the MAF sensor code DOES happen a bit on '13+. WHAT?!? He said he did not turn that code off in my ECU as it is usually not an issue with N/A cars. I hope it is as simple as turning off the code. We shall see.
4DRZ is offline   Reply With Quote
Old 10-12-2017, 06:49 PM   #10
BigRek718
Registered User
Thread Starter
 
BigRek718's Avatar
 
Join Date: Jun 2017
Posts: 31
Thanked 0 Times in 0 Posts
I also have no issues what so ever with my Z1 Intakes. I also was stuck in a HUGE rainstorm and had no issues with the filters getting wet. I stopped under some cover and checked the filters.
BigRek718 is offline   Reply With Quote
Old 10-12-2017, 11:56 PM   #11
4DRZ
Registered User
iTrader: (4)
 
4DRZ's Avatar
 
Join Date: Sep 2015
Location: Appleton, WI
Posts: 1,774
Thanked 143 Times in 119 Posts
Quote:
Originally Posted by BigRek718 View Post
I also have no issues what so ever with my Z1 Intakes. I also was stuck in a HUGE rainstorm and had no issues with the filters getting wet. I stopped under some cover and checked the filters.
Do you just have the intakes or other parts and a tune?
4DRZ is offline   Reply With Quote
Old 10-13-2017, 01:25 AM   #12
BigRek718
Registered User
Thread Starter
 
BigRek718's Avatar
 
Join Date: Jun 2017
Posts: 31
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 4DRZ View Post
Do you just have the intakes or other parts and a tune?
As of now, just the intakes.
BigRek718 is offline   Reply With Quote
Old 10-14-2017, 04:31 PM   #13
slartibartfast
Registered User
iTrader: (4)
 
Join Date: Oct 2014
Location: Houston, Tx
Posts: 2,001
Thanked 174 Times in 159 Posts
Come on guys, this is the review forum. The discussion needs to move to the tech forum.
slartibartfast is offline   Reply With Quote
Old 10-14-2017, 08:17 PM   #14
4DRZ
Registered User
iTrader: (4)
 
4DRZ's Avatar
 
Join Date: Sep 2015
Location: Appleton, WI
Posts: 1,774
Thanked 143 Times in 119 Posts
I think it is important for people to understand that there are some serious issues with Z1 and their tune related to these intakes.
4DRZ is offline   Reply With Quote
Old 10-16-2017, 09:04 AM   #15
lorentzoe45
Premier Member
iTrader: (3)
 
lorentzoe45's Avatar
 
Join Date: Jun 2015
Location: Gwinnett County, Georgia
Posts: 411
Thanked 32 Times in 29 Posts
Quote:
Originally Posted by 4DRZ View Post
I think it is important for people to understand that there are some serious issues with Z1 and their tune related to these intakes.
Do yourself a favor, sell them and get Stillen Gen 3 or something like that. I had the z1 intakes for couple months or so. Z1 products are hit or miss. For me the z1 intake filtered poorly also. Lots of dirt in the pipe. I have some products that I like from them and some I canít stand. Also not a fan of how the filters are not secured to anything and are very wobbly. Sorry your having problems, hope you get it figured out
lorentzoe45 is offline   Reply With Quote
The Following User Says Thank You to lorentzoe45 For This Useful Post:
4DRZ (10-16-2017)
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 12:09 AM.


Copyright ©2002 - 2017, MYG37.COM All Rights Reserved.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: