Go Back  MyG37 > Tech Area > Audio, Video & Electronics
Reload this Page >

Turn signals don't work after resetting car electronics

Notices
Audio, Video & Electronics Post questions, reviews, and other general info about the G's Nav, sound system, satellite radio or aftermarket stereos

Turn signals don't work after resetting car electronics

Old 04-14-2019, 06:50 PM
  #1  
mathmusicmikey
Registered User
Thread Starter
 
Join Date: Aug 2016
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
Turn signals don't work after resetting car electronics

The yellow key display appeared and stayed on, on the dash of my 2013 G7x. Then the radio, wipers, nav display all shut down one by one. Then the engine wouldn't turn off, though the all the dash diplays turned off. I left it running for 10 mins, after which i turned off successfully. I did a reset, following instructions I found in one of the forums on here. The car started fine, the yellow key display disappeared, but now the turn signals don't work. The hazards do work.

Any thoughts? Help!
mathmusicmikey is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Matty_baby
Picture Share G Coupe
21
02-06-2019 03:09 AM
slotterjordan
G37 Coupe
8
11-24-2018 02:58 AM
Diode Dynamics
Lighting/Cleaning Products
105
04-13-2017 03:54 PM
monto18
Body Interior Exterior Lighting
3
06-17-2008 11:57 AM


Thread Tools
Search this Thread
Quick Reply: Turn signals don't work after resetting car electronics


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.