iPhone connectivity issues - Page 12 - MyG37

Go Back  MyG37 > Tech Area > Audio, Video & Electronics
Reload this Page >

iPhone connectivity issues

Notices
Audio, Video & Electronics Post questions, reviews, and other general info about the G's Nav, sound system, satellite radio or aftermarket stereos

iPhone connectivity issues

Reply

 
 
 
Old 09-20-2018, 10:56 PM
  #166  
codeflux
Registered User
iTrader: (12)
 
codeflux's Avatar
 
Join Date: May 2004
Location: San Francisco, CA
Posts: 130
Thanked 12 Times in 12 Posts
Heh well then technically I'm Ukrainian.

Last edited by codeflux; 09-21-2018 at 12:02 PM.
codeflux is offline  
Reply With Quote
Old 09-25-2018, 11:12 PM
  #167  
codeflux
Registered User
iTrader: (12)
 
codeflux's Avatar
 
Join Date: May 2004
Location: San Francisco, CA
Posts: 130
Thanked 12 Times in 12 Posts
OK, so this is annoying. I was listening to a podcast (as opposed to hella loud music) and heard random clicks, one or two each second. Switched back to USB input - no clicks. Dammit Apple!
codeflux is offline  
Reply With Quote
Old 09-27-2018, 01:00 AM
  #168  
sev1980
Registered User
 
Join Date: Mar 2016
Posts: 65
Thanked 10 Times in 9 Posts
This morning i made an outgoing call and it was all choppy like before. a2dp seems to work like 80% better but the other 20% i want to burn the car down. How hard is it for nissan to design a working bluetooth solution?!

Im ready to rip the entire system out and get one of those android grom units. Are those only for non navigation systems?
sev1980 is offline  
Reply With Quote
Old 09-27-2018, 01:05 AM
  #169  
codeflux
Registered User
iTrader: (12)
 
codeflux's Avatar
 
Join Date: May 2004
Location: San Francisco, CA
Posts: 130
Thanked 12 Times in 12 Posts
Sigh, probably easier to just get a new car... Or newer car. I've been toying with an idea of Q50 or a Bimmer. or a Tesla. Or a pre-dinged Nissan Sentra so i wouldn't worry about parking it anywhere.
codeflux is offline  
Reply With Quote
Old 09-27-2018, 03:45 PM
  #170  
audiRS4ever
Registered User
 
Join Date: Apr 2016
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
Related issue here - received my new iPhone the other day and now, when plugging into the car via USB, the album art and song info don't show up. They play OK, but the screen just says "No Song Available" or something of that nature.

Not sure if this would be related to the hardware or the iOS12 OS. Either way, has anyone else seen this happen?
audiRS4ever is offline  
Reply With Quote
Old 09-27-2018, 07:36 PM
  #171  
codeflux
Registered User
iTrader: (12)
 
codeflux's Avatar
 
Join Date: May 2004
Location: San Francisco, CA
Posts: 130
Thanked 12 Times in 12 Posts
are you playing tracks from your local music library?

if yes, then i have no idea.

if not, and if your local music library is empty, go to itunes and download any free music track to your phone. that should fix it.
codeflux is offline  
Reply With Quote
Old 10-03-2018, 02:43 PM
  #172  
sev1980
Registered User
 
Join Date: Mar 2016
Posts: 65
Thanked 10 Times in 9 Posts
So i have a new issue with that last update. Either its ios12 or it's the itb-054b. Phone calls come in and work but a few mins into the call the voice on the other side gets choppy and stops working.

I still cannot understand why it's so hard for infiniti to fix this issue.
sev1980 is offline  
Reply With Quote
Old 10-03-2018, 02:45 PM
  #173  
codeflux
Registered User
iTrader: (12)
 
codeflux's Avatar
 
Join Date: May 2004
Location: San Francisco, CA
Posts: 130
Thanked 12 Times in 12 Posts
you could set the do-not-disturb-while-driving - problem solved?... sigh...
codeflux is offline  
Reply With Quote
Old 10-03-2018, 05:08 PM
  #174  
sev1980
Registered User
 
Join Date: Mar 2016
Posts: 65
Thanked 10 Times in 9 Posts
Im thinking about picking up a clone Nissan Consult 3 diagnostic tool and setting it up on my computer to see if i can read/write to the AV module and do some experimentation. Looks like the Consult III is good for model year 2010, after that it requires the consult III+ which costs 600 bucks. The regular Consult III is only 135 bucks.

If it gives me the ability to flash different firmwares and experiment. Maybe it'll be worthwhile.

I have experience with hacking around older chrysler ECUs and older BMW ecus. Nissans are pretty foreign to me. Alot more support for BMW ECU stuff out there than nissan. Kind of interesting.
sev1980 is offline  
Reply With Quote
Old 10-03-2018, 10:45 PM
  #175  
sev1980
Registered User
 
Join Date: Mar 2016
Posts: 65
Thanked 10 Times in 9 Posts
So I spent a ton of time today loading up the nav firmware update DVD and poking around. I found the bluetooth firmware on the DVD and spent some time Hex editing it and looking through. I'm looking to see who makes the bluetooth chip inside the navigation system, maybe we can track down a fix that route rather than relying on nissan. I didnt find much info in there, but I found some kind of interesting stuff even still. Looks like whoever wrote the firmware, somehow compiled paths and locations to the code and libraries they were working on in the firmware file. Lots of references that have nothing to do with anything, E.g. C:\SourceCode\120406_A3P_E0450\atcommand\at_cmd_sy ncml.c baked into the firmware file. To me this reeks of laziness.

So I took it a step further. I took apart my dash and pulled out the navigation unit and carefully took it apart. JEEZ that thing is insanely complicated. The unit has 4 different circuit boards stacked on top of eachother, and one more in the front. It was nerve wracking taking it apart without damaging anything. I am happy to say I was able to take it apart, and put it back together without damaging anything. Plus I got some good info to go off of. I actually found the manufacturer of the bluetooth chip in the unit. Here it is!
This is the actual chip that's used in our cars:

https://www.alps.com/prod/info/E/HTM...ZC-5_list.html

This is the module built specifically for our cars:
https://fccid.io/SJ2HGZ0024/Label/label-info-1071893

Yuck no wonder a2dp sounds so bad. Its bluetooth v1.2!!!!!

I need to continue to do some more research. This all may be a dead end. But maybe we'll get lucky and hit paydirt.

Why would I spend so much time on this? Well I love literally everything about my car except for the bluetooth. IF I can fix that then I'm a happy camper. Plus I love tinkering.

I took a ton of pictures of the inside of the unit. I'll post them up later.

Last edited by sev1980; 10-03-2018 at 10:53 PM.
sev1980 is offline  
Reply With Quote
Old 10-06-2018, 03:57 PM
  #176  
codeflux
Registered User
iTrader: (12)
 
codeflux's Avatar
 
Join Date: May 2004
Location: San Francisco, CA
Posts: 130
Thanked 12 Times in 12 Posts
^^^ mind blown.

on to more annoying. the "disconnect of death" is back. i was listening to music over BT, and about 10 minutes into it the phone disconnects, and the car tries to reconnect for a few seconds, then "Not registered" message, and on to the disconnect->reconnect cycle.

pretty much giving up on this, and went back to using USB input.
codeflux is offline  
Reply With Quote
Old 10-08-2018, 02:43 PM
  #177  
sev1980
Registered User
 
Join Date: Mar 2016
Posts: 65
Thanked 10 Times in 9 Posts
Been doing a bunch of research, and looks like there is a newer bluetooth module used on these units that supports bluetooth 2.0.

My 2010 EX has the HGZ0024 bluetooth unit which seems to be bluetooth 1.2. The found that there is a HGZ0025 module that clarion's documentation says is bluetooth 2.0. My guess is that the later nav units (2013+) use this module and that's why we dont hear of people with later infinitis having the same problems. Going to do some more digging. I'd like to get my hands one one of these modules but in order to do so I'd have to find a newer unit in the junkyard or such. Sadly my local boneyard had a 2013 and a 2015 infiniti in it but at the time I didnt think to rip out the head unit. Which was literally just sitting there.

This is all just a guess at this point My thought is if we can just transplant the bluetooth module to our car, there shouldn't be a need for any programming or coding, since nothing in the head unit changes except for the bluetooth module. Just a theory for now. More as I discover more.

https://fccid.io/ANATEL/01148-14-047...CA47462651/PDF

Unfortunately I haven't been able to find any newer bluetooth firmware past e0450 for our units. So maybe trying to score a newer module might be the way to go.
sev1980 is offline  
Reply With Quote
Old 10-08-2018, 04:43 PM
  #178  
sev1980
Registered User
 
Join Date: Mar 2016
Posts: 65
Thanked 10 Times in 9 Posts
Hey Codeflux. I started a separate thread on the hardware stuff for the infotainment system. I'll leave this thread for direct talk about Bluetooth issues. Follow me there if interested.
sev1980 is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread

Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.