Go Back   MyG37 > Tech Area > TSB - Technical Bulletins
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Search Today's Posts Mark Forums Read GarageUsed CarsvBLiveVendor Directory TSBs
Search

Welcome to myG37 forums!
Welcome to myG37 Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join myG37 Forums today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 02-17-2011, 03:59 PM   #1
PR_G37
Registered User
 
Trader Score: (0)
Join Date: Aug 2009
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
C'mon Infiniti! Bad battery, bad brakes, bad battery again

My car = 2009 G37S sedan

Car wasn't a year old and my battery kept dying and eventually couldn't be jump started anymore. Got towed to dealership and they ran tests and said it was a bad battery, not an electrical issue. They replaced the battery under warranty.

Then my back brakes were giving me trouble. Same dealership checked them out and said the back brake plates (?) were faulty and they replaced those under warranty.

Now my "new" car battery, almost one year old but not quite, has died 3 times in the past 2 weeks. I'm taking the car in for tests at another dealership in a few days. Has anybody else experienced these types of annoyances too?
PR_G37 is offline   Reply With Quote
Sponsored Links
Old 02-17-2011, 04:05 PM   #2
Felix_the_Cat
Registered User
 
Trader Score: (2)
Join Date: Feb 2010
Location: Modesto, NorCal
Posts: 290
Thanks: 0
Thanked 0 Times in 0 Posts
There's was a tsb to replace something to due with the vents inside the car that would cause the battery to die something like that at least I don't really recall. I got that and the battery replaced free under warranty. No more battery issues since. Btw its INFINITI
Felix_the_Cat is offline   Reply With Quote
Old 02-17-2011, 05:31 PM   #3
PR_G37
Registered User
 
Trader Score: (0)
Join Date: Aug 2009
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Re: spelling - I know that, just making sure you're all still awake

Seriously, this battery thing is turning into a debacle. I suspect something in the electronics of the car that's amiss. New cars should not have brake and battery issues within the first year. Whatever was wrong with the car when the first battery failed should've been caught by the dealership.
PR_G37 is offline   Reply With Quote
Old 02-17-2011, 08:15 PM   #4
emyrl
Registered User
 
Trader Score: (13)
Join Date: May 2008
Location: Cupertino(Norcal)/Irvine(SoCal)
Posts: 715
Thanks: 0
Thanked 0 Times in 0 Posts
Yea the whole battery issue was pretty annoying. Had mine replaced twice. Second time they also did a TSB and replaced my Vent Control Valve...or something like that and upgraded my battery. You're battery should be fine after that. Can't help you with your brakes though, haven't had a problem there.
__________________
08VR 5AT with stuff.
emyrl is offline   Reply With Quote
Old 02-17-2011, 08:27 PM   #5
PR_G37
Registered User
 
Trader Score: (0)
Join Date: Aug 2009
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for heads up about vent control valve. My brakes also squeak like hell to an embarrassing extent. Just commented on an old post about it from someone else who also has squeaky brakes. Two dealers have checked my brakes and said they look fine. But now I digress.
PR_G37 is offline   Reply With Quote
Old 03-01-2011, 12:34 AM   #6
MACS
Registered User

 
MACS's Avatar
 
Trader Score: (3)
Join Date: Mar 2005
Location: SoCal (Shawn)
Posts: 1,273
Thanked 19 Times in 16 Posts
You must have bought a Friday car. Everyone knows you want a Wednesday car!

Monday - hung over, tired from the weekend... not paying attention
Tuesday - better than monday, not quite into the swing of things yet
Wednesday - totally focused on work!
Thursday - thinking about friday
Friday - thinking about clubbin' with the hotties
__________________
2014 Tacoma Dbl Cab, V6, 4x4, TRD Sport... loaded.
MACS is offline   Reply With Quote
Old 03-03-2011, 10:49 PM   #7
carolsueg
Registered User
 
Trader Score: (0)
Join Date: Mar 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
any resolution - just replaced the original battery on 2/14 - battery died yesterday - charged today - and dead again!
carolsueg is offline   Reply With Quote
Old 03-04-2011, 11:44 AM   #8
Calgarywinger
Registered User
 
Trader Score: (0)
Join Date: Aug 2009
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
'09 Vert, battery died after 2 years. Printed the 08/09 TSB and took it to the dealer. They replaced the EVAP and the battery, no questions, no hassles, and no problems.
TSB : Knowledgebase - 2009 G37 Coupe - Infinitihelp.com Forums
"2008-2009 INFINITI G37 COUPE; BATTERY LOW VOLTAGE / NO START
An Applied Vehicle has a Battery Low Voltage or no start condition due to specific customer use pattern
Calgarywinger is offline   Reply With Quote
Old 03-08-2011, 06:35 PM   #9
PR_G37
Registered User
 
Trader Score: (0)
Join Date: Aug 2009
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Glad to see my post here is still alive because I have an update (at the same time I'm not glad this post is still alive because this battery issue shouldn't exist for anyone!).

So the dealer replaced my battery (this is the 2nd battery replacement I've had) and also fixed the vent valve issue which causes the battery to drain - there is a TSB for this as Felix_the_Cat and emyrl noted above.

But here's the kicker, a few days after getting my car back with these fixes, I pressed to turn on the engine and everything kicked on with flying colors, but then the engine started getting quieter and quieter and quieter until everything shut off by itself (all happened very quickly). When I pressed to turn on the engine again, it turned on and stayed on.

This hasn't happened again since, but this is not a good omen. After the recent fixes the dealer made to my car (new battery + no more vent valve issue), my engine does turn on quicker than it did before, but I still feel like it should turn on faster. When my car was at the dealership, they loaned me a brand new G37 with about 2k miles on it and when I pressed to turn it on, it turned on FAST. I could be imagining things, but I swear it still sounds like my car's engine is losing a little steam every time I turn it on. I hope I'm wrong, but given the random troubles I've had, I wouldn't be surprised if another battery or electrical issue pops ups again. Wish I could have more confidence than that in my car.
PR_G37 is offline   Reply With Quote
Old 03-08-2011, 06:52 PM   #10
madmax2k1
Registered User
 
Trader Score: (0)
Join Date: Sep 2007
Location: OC CA
Posts: 640
Thanks: 0
Thanked 1 Time in 1 Post
Make sure they gave you the battery from the Infiniti M model which has a higher cranking power; the part number is QC24F.
__________________
09 G37S Sedan 6MT, Nav, Premium, Spoiler
madmax2k1 is offline   Reply With Quote
Old 03-10-2011, 04:48 PM   #11
PR_G37
Registered User
 
Trader Score: (0)
Join Date: Aug 2009
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Just checked the paperwork from the dealer - they did indeed give me the QC24F battery. The other night, my car had another start-up and almost-immediate-shut-down episode again. Fortunately nothing happened. I hate to jinx myself but this car is turning into trouble after exactly 2 years of ownership (well luckily I'm leasing...I mean thank the higher powers that be I didn't purchase).
PR_G37 is offline   Reply With Quote
Old 08-23-2011, 04:22 PM   #12
shieldsie
Registered User
 
Trader Score: (0)
Join Date: Feb 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Yes, four times back to the dealer and six jump starts. They reprogrammed the damn thing twice and put in two new batteries and I'm still having problems.
shieldsie is offline   Reply With Quote
Old 08-23-2011, 04:22 PM
MyG37
Infiniti G37




Paid Advertisement
 
 
 
submit to reddit
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 09:10 AM.

Copyright 2002 - 2009, MYG37.COM All Rights Reserved.



Contacts Backup

Search Engine Friendly URLs by vBSEO 3.5.2