Go Back   MyG37 > G-Spot > G37 Coupe
Sign in using an external account
Register Forgot Password?
Search

Welcome to myG37 forums!
Welcome to myG37 Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join myG37 Forums today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 05-24-2009, 01:43 AM   #1
DPE_G35
Registered User
 
Trader Score: (0)
Join Date: Feb 2007
Posts: 167
Thanks: 0
Thanked 0 Times in 0 Posts
vdc and slip light is on

hey,

i've noticed this promblem since last week, when ever i push the car over 5-6 rpms my vdc and slip light goes on and stays on till i turn the car off and then it goes away when i start it back up, and i notice that my brake light comes on too but doesnt stay on like the vdc and slip light.
DPE_G35 is offline   Reply With Quote
Sponsored Links
Old 05-24-2009, 02:27 AM   #2
Dimitry6
Registered User
 
Trader Score: (0)
Join Date: Jan 2009
Location: Broooklynnnn
Posts: 354
Thanks: 0
Thanked 0 Times in 0 Posts
Its your brakes like 90% check them out had same problem on my g35 before.....and check your wheels while your at it
Dimitry6 is offline   Reply With Quote
Old 05-24-2009, 04:55 AM   #3
XMMAN
Registered User
 
Trader Score: (0)
Join Date: Jan 2009
Posts: 545
Thanked 1 Time in 1 Post
Quote:
Originally Posted by Dimitry6 View Post
Its your brakes like 90% check them out had same problem on my g35 before.....and check your wheels while your at it

would that mean the brakes are running low? what would the wheels have to do with it?
__________________
http://www.SiriusXM.com
XMMAN is offline   Reply With Quote
Old 05-24-2009, 12:51 PM   #4
Michelangelo
Registered User
 
Trader Score: (0)
Join Date: Mar 2009
Location: Northern Virginia
Posts: 173
Thanks: 0
Thanked 0 Times in 0 Posts
According to the manual, if the VDC OFF and SLIP lights illuminate constantly while the car is running, there may be problem with the VDC system and it is operating in "fail-safe mode." The car will still be drivable but you should take it to the dealer ASAP.
__________________
2012 G37x Sedan - Malbec/Wheat/Maple - Prem/Nav/7AT/Splash Guards/Illuminated Kicks
Michelangelo is offline   Reply With Quote
Old 05-24-2009, 12:54 PM   #5
nostalgia85
Registered User

 
Trader Score: (0)
Join Date: Feb 2009
Location: NJ bergen county
Posts: 153
Thanks: 0
Thanked 0 Times in 0 Posts
its 99% your brake. get your brake pad check. im pretty sure you only have like 2-4 mm left.
nostalgia85 is offline   Reply With Quote
Old 05-24-2009, 01:36 PM   #6
JDM
Registered User
 
Trader Score: (3)
Join Date: May 2008
Location: New York City
Posts: 304
Thanks: 0
Thanked 0 Times in 0 Posts
i have the same problem, my car only has 4000 miles.....
JDM is offline   Reply With Quote
Old 05-24-2009, 03:26 PM   #7
Mike
Registered User
 
Trader Score: (1)
Join Date: Feb 2008
Posts: 4,559
Thanks: 0
Thanked 4 Times in 4 Posts
Check brakes and tires first (fluid levels, pad left, and tires/rims for damage, torque lugs to spec).

Then, check your alignment if you still havn't solved it.
Mike is offline   Reply With Quote
Old 05-26-2009, 09:02 PM   #8
flagrant
Registered User

 
Trader Score: (1)
Join Date: May 2009
Posts: 134
Thanks: 0
Thanked 0 Times in 0 Posts
check the brake fliud........
flagrant is offline   Reply With Quote
Old 05-28-2009, 10:48 PM   #9
sofakingspeshul
Registered User
 
Trader Score: (1)
Join Date: Oct 2008
Location: Chicago, IL
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
i actually recently had that problem as well. the first time i took the car in because of the lights, they diagnosed it as my ABS actuator that had went out on me. However, that had happened a second time.. the second time they just needed to adjust something on the brake pedal. Hopefully your situation just calls for adjusting of the brake pedal.
__________________
2007 ducati monster s2r1k few goodies // 2008 g37s OB sadly still bone stock
sofakingspeshul is offline   Reply With Quote
Old 11-05-2010, 12:49 AM   #10
RochesterG37
Registered User

 
Trader Score: (0)
Join Date: Feb 2009
Location: rochester ny
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
i have same problem, i have not taken to dealer yet but i was wondering how you made out?????? please post thanks!
RochesterG37 is offline   Reply With Quote
Old 11-05-2010, 12:58 AM   #11
STOOF
Registered User

 
STOOF's Avatar
 
Trader Score: (2)
Join Date: Mar 2007
Location: Staten Island, NY
Posts: 2,909
Thanks: 0
Thanked 1 Time in 1 Post
check your brake pads and brake fluid first.

Mine came one once cause my fuse for my taillights blew out.
__________________
2011 BMW Z4 SDrive35i~JB4~DCI~Eisenmann~400+RWHP~
STOOF is offline   Reply With Quote
Old 11-05-2010, 01:11 AM   #12
wakeboardr116
Registered User

 
Trader Score: (6)
Join Date: Dec 2007
Location: Oklahoma
Posts: 3,307
Thanked 4 Times in 4 Posts
Your brake fluid is low. Fill it up and it will go away.
__________________
Tanabe|Injen|Berk|Megan|Hotchkis|StopTech|UpRev|Autokits X|180 Customs|Advan|SOLD 3/14
wakeboardr116 is offline   Reply With Quote
Old 11-05-2010, 01:23 AM   #13
KAHBOOM
Moderator of Pwnage
 
KAHBOOM's Avatar
 
Trader Score: (0)
Join Date: Jun 2003
Location: NC
Posts: 1,939
Thanked 9 Times in 8 Posts
Yep had this issue a while back... I was low on brake fluid
KAHBOOM is offline   Reply With Quote
Old 11-23-2010, 11:15 PM   #14
Wezbian
Registered User

 
Wezbian's Avatar
 
Trader Score: (3)
Join Date: Mar 2007
Location: Sacramento
Posts: 857
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via AIM to Wezbian
Umm it makes sense guys. When you accelerate hard the fluid in the master cylinder moves towards the back and obviously sets off the level light. If the brake fluid level is low then abs and vdc (which uses brakes) will fault too. I just had this occur tonight and was freaked out! I'm going to check levels and let you guys know the results.
Wezbian is offline   Reply With Quote
Old 11-24-2010, 06:08 PM   #15
Justin311
Registered User
 
Trader Score: (1)
Join Date: Dec 2008
Posts: 100
Thanks: 0
Thanked 1 Time in 1 Post
It can be the pads too, as others mentioned, doesn't have to be the fluid. I tried adding fluid since I still had ~15% of pads left on my 07 G35X @ 75k. Didn't help. So I replaced the pads and rotors and the light hasn't come back in 10k and over a year.
__________________
6MT 08 G37S|G35X 07 Sedan|08 Tundra|400whp 93 MR2|Supercharged 03 Spyder| Wrangler|
Justin311 is offline   Reply With Quote
Old 11-24-2010, 06:08 PM
MyG37
Infiniti G37




Paid Advertisement
 
 
 
submit to reddit
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 12:56 AM.

Copyright 2002 - 2009, MYG37.COM All Rights Reserved.



Contacts Backup