Go Back   MyG37 > Tech Area > Brakes, Suspension, Wheels & Tires
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Search Today's Posts Mark Forums Read GarageUsed CarsVendor DirectoryvBLive TSBs
Search


Welcome to myG37 forums!
Welcome to myG37 Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join myG37 Forums today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 05-21-2010, 09:46 PM   #1
SlateBlue G
Registered User
 
Trader Score: (2)
Join Date: Oct 2007
Location: NY
Posts: 175
Thanks: 0
Thanked 1 Time in 1 Post
Steering wheel vibration comes and goes

So I have this problem it's just driving me nuts.Speeds 60-70 steering wheel is perfect at times then shakes at times when cruising.I have aftermarket wheels with hub ring and alignment just done with roadforce balance. Any suggestions?

Last edited by SlateBlue G; 05-22-2010 at 01:49 AM..
SlateBlue G is offline   Reply With Quote
Sponsored Links
Old 05-21-2010, 09:54 PM   #2
G37Sam
Administrator

 
G37Sam's Avatar
 
Trader Score: (0)
Join Date: Aug 2008
Location: Dubai, UAE
Posts: 11,896
Thanked 126 Times in 99 Posts
Does it only occur under braking or just when cruising?
__________________
'08 G37 Coupe - RB Powered
Quick Specs | Build Thread


Before you post:
- Check out this lovely feature!
- Read our Guidelines
- Read the forum rules
- Learn how to post
G37Sam is offline   Reply With Quote
Old 05-21-2010, 10:11 PM   #3
SlateBlue G
Registered User
 
Trader Score: (2)
Join Date: Oct 2007
Location: NY
Posts: 175
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by G37Sam View Post
Does it only occur under braking or just when cruising?
Cruising
SlateBlue G is offline   Reply With Quote
Old 05-21-2010, 10:41 PM   #4
Loi
Registered User
 
Loi's Avatar
 
Trader Score: (12)
Join Date: Jan 2008
Location: Central and South Florida
Posts: 1,342
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Loi
Do you have the right size hub rings? It's suppose to be a snug fit.
Loi is offline   Reply With Quote
Old 05-22-2010, 02:20 PM   #5
SlateBlue G
Registered User
 
Trader Score: (2)
Join Date: Oct 2007
Location: NY
Posts: 175
Thanks: 0
Thanked 1 Time in 1 Post
Click the image to open in full size.
Click the image to open in full size.

only thing I can see that is a very small gap after the hub to the end of the wheel.
SlateBlue G is offline   Reply With Quote
Old 05-22-2010, 02:34 PM   #6
Mike
Registered User
 
Trader Score: (1)
Join Date: Feb 2008
Posts: 4,559
Thanks: 0
Thanked 2 Times in 2 Posts
Have you had your wheels rebalanced?

Tires don't wear perfectly evenly, and it sounds like it could be a balancing issue.
Mike is offline   Reply With Quote
Old 05-22-2010, 02:44 PM   #7
VossenG37S
Registered User
 
Trader Score: (16)
Join Date: Jul 2008
Location: Miami,Florida
Posts: 5,924
Thanks: 0
Thanked 3 Times in 3 Posts
I have exact same problem.
VossenG37S is offline   Reply With Quote
Old 05-22-2010, 02:56 PM   #8
Loi
Registered User
 
Loi's Avatar
 
Trader Score: (12)
Join Date: Jan 2008
Location: Central and South Florida
Posts: 1,342
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Loi
Can't really see any gap int he pics, but I ordered hub rings and they sent me the wrong size, just 1mm too big, and it's causing vibration.
Loi is offline   Reply With Quote
Old 05-22-2010, 03:01 PM   #9
Loi
Registered User
 
Loi's Avatar
 
Trader Score: (12)
Join Date: Jan 2008
Location: Central and South Florida
Posts: 1,342
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Loi
and yea, I know how you feel when it starts shaking, I would start to think omg is my tires about to blow? or my lugs coming loose and my rims gonna go flying off?!! lol
Loi is offline   Reply With Quote
Old 05-27-2010, 09:51 AM   #10
SlateBlue G
Registered User
 
Trader Score: (2)
Join Date: Oct 2007
Location: NY
Posts: 175
Thanks: 0
Thanked 1 Time in 1 Post
Problem solved.after I drove couple hundred miles after new tires the balance was all wacked out.no vibrations now after new balance
SlateBlue G is offline   Reply With Quote
Old 05-27-2010, 09:51 AM
MyG37
Infiniti G37




Paid Advertisement
 
 
 
submit to reddit
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 03:52 PM.

Copyright 2002 - 2009, MYG37.COM All Rights Reserved.



Contacts Backup